Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Questions

Tags disappearing



AuthorMessage
The Guarnieri's

Posted: Mar 18, 2013
Score: 0



Just today my Tags started to behave oddly. While they are all still in each Task, when I select the By Tag view, only 2 of 5 possible tags show up as selectable. If then go to All Tags and remove and re-add a tag missing from the list, it reappears for a bit. But then will disappear with a few minutes of using Toodledo.

Any thoughts on what is causing this behavior?
KatBoy

Posted: Mar 18, 2013
Score: 0



This happened to me a few weeks ago; issued a Support Ticket but bug couldn't be replicated...

In the meantime, missing tags reappeared.
Jake

Toodledo Admin
Posted: Mar 18, 2013
Score: 0



For efficiency, we cache the list of tags, since it would be slow to recalculate this list all the time. We try to keep the cache in sync with the actual list, but sometimes it can get out of sync. To combat this, once a day we recalculate the tag cache from scratch. This would explain why it only misbehaves for a day and then starts working again.

We don't yet know how it gets out of sync, but we are looking into it.
daniel_h

Posted: Apr 13, 2013
Score: 0



hi,
I have been changing the way I use tags in my entire task list. I notice that if I go into tag view, the number of tags listed next to the tags is off on a number of the "changed" or new tags. for instance, I have one tag that in the left side vertical bar has a "6" next to it. when I click on that tag, the list of tasks has at least double that number.

for another tag, it lists that there is "1" task. if I click on that tag to view, there are no tasks listed, but instead the message that some filters are hiding my tasks. I click to turn off the filters, but the task still does not appear. I think this might be because toodledo is confused. the task in question is an old task that was completed a long time ago, but recently changed (by changing the task). the only way to see this task is to search for completed items. but why is there a "1" next to the tag on the tag view screen?

so, to further point out the issue, this is on the web. if I go to the iPhone app, the task numbers are correct and the above issue does not seem to exist.

if both of these issues has to do with the caching error mentioned, at what time does the re-cache recalculation happen? I will be interested to see if this resolves itself, or if there is a more serious bug...


This message was edited Apr 13, 2013.
Jake

Toodledo Admin
Posted: Apr 15, 2013
Score: 0



If you refresh the page, does it make a difference?
daniel_h

Posted: Apr 15, 2013
Score: 0



refreshing page did not make a difference over a couple of hours. I checked back yesterday, and it seemed to resolve. could this have to do with the tags cache happening daily? I really was changing a lot of tags, and this issue had to do with previously completed tasks having their tags changed.
thanks.
Jake

Toodledo Admin
Posted: Apr 15, 2013
Score: 0



We recalculate the tags once a day. They should stay in sync with your list, but sometimes they can get out of order until we recalculate. It is very expensive (in processing time) to recalculate which is why we do it only once a day.
You cannot reply yet


To participate in these forums, you must be signed in.



Toodledo Forums > Questions