Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Questions

Exporting tasks to CSV format with foreign characters



AuthorMessage
mr_many_notes

Posted: Sep 11, 2009
Score: 0



Hi,

I'm having problems doing an export to CSV of tasks where they contain foreign characters such as the French accented e (é).

What I want in the export file is this:
déprimer

What I get is this:
déprimer

Any ideas? Thanks.
Anders

Posted: Sep 11, 2009
Score: 0



Are you using Excel? It is kind of a pain to work with different text encodings on Excel, but here is what I would do.
-Instead of downloading the CSV, click "View File"
-Using your browser menu, save the page as text
-Open Excel (don't open the document with Excel, just open Excel)
-Click on "Open" in Excel
-Browse and select the export file you saved as text
-The text import wizard will appear
-For "Data Type" choose "Delimited"
-For "File Origin" choose "Unicode (UTF-8)". There will be a preview window that will show you if this looks right.
-On the next screen, for "Delimiters", choose "Comma" and unselect anything else.
-On the next screen, I would change each column except Priority from "General" to "Text" but that is probably not necessary.

I think that should do the trick.
mr_many_notes

Posted: Sep 12, 2009
Score: 0



Hi,

Thanks for the suggestion. Unfortunately, although it converts the characters correctly, overall it doesn't work because each of my tasks has a multi-line note, which displays (of course) on a separate line for each line, and so looks like lots of different tasks.

To give a simplified example of something which should be just 1 excel row, but looks to the system like 3 rows (i.e. 3 tasks):
TASK, NOTE
"my task", "my note line 1
my note line 2
my note line 3"

I also tried to point Excel at the CSV file downloaded (rather than the one saved as text), as follows:
Data->Import External Data->Import Data

This also gave the same multi-line problem.

Any other ideas? Thanks.
IceHeartX

Posted: Sep 12, 2009
Score: 0



Posted by mr_many_notes:
Hi,

Thanks for the suggestion. Unfortunately, although it converts the characters correctly, overall it doesn't work because each of my tasks has a multi-line note, which displays (of course) on a separate line for each line, and so looks like lots of different tasks.

To give a simplified example of something which should be just 1 excel row, but looks to the system like 3 rows (i.e. 3 tasks):
TASK, NOTE
"my task", "my note line 1
my note line 2
my note line 3"

I also tried to point Excel at the CSV file downloaded (rather than the one saved as text), as follows:
Data->Import External Data->Import Data

This also gave the same multi-line problem.

Any other ideas? Thanks.


there should be an option when you import to specify if the values are quoted. if they are, it shouldn't care about the newlines.
Anders

Posted: Sep 12, 2009
Score: 0



I just tried this out, and I don't think it is line breaks. I think it is commas in the note. For some reason, even if they are between quotes, Excel still want to move everything after a comma to a new cell. I have two more ideas, but I will have to try them out in a bit.
Edit: Nope, it's commas and linebreaks both.


This message was edited Sep 12, 2009.
Anders

Posted: Sep 12, 2009
Score: 0



Mr. ManyNotes, I have tried several things with no luck. I don't know why Office apps have to be so finicky. I can open a document in Word, and have it automatically ask me what encoding to convert from, but it seems that this is not possible in Excel. There is probably a good way to do this, but I can't figure it out. Hopefully someone else has an idea. How many different foreign characters do you have in your whole (no doubt enormous) export file? If it is not more than a dozen or so, the best thing to do may be to use Excel's "find & replace" function to set them all straight.
Anders

Posted: Sep 23, 2009
Score: 0



I just realized there is another option. You can just use the XML export. I don't know why I didn't think of that before. Excel can open it as an XML table, and it will not change the foreign characters.
You cannot reply yet


To participate in these forums, you must be signed in.



Toodledo Forums > Questions