ForumsQuestionsHiding future tasks


Hiding future tasks
Author Message
PeterW 

Posted: Mar 07, 2010
Score: 0 Reference
Hi there,

I have a questions about hiding future tasks.

Toodledo Help says:

How do due date modifiers work?

Due date modifiers can be selected when entering a due date.

Due by:
This is the default value. It means that a task must be due before this date passes.

Due on:
Sometimes a task can only be completed on a specific due date (like a dentist appointment) and being reminded about it ahead of time is unnecessary. You can fix this by setting it to be due "on" the date. The abbreviation for this is an equals sign in front of the date. For example "=2008-01-01". This signifies that this task can only be completed on Jan 1, 2008 and that we shouldn't worry about it until then.

I have a repeating task set for every Friday at 2:00pm. If I set it to be "due on" I assumed that I would not see it until Friday arrived. This is not the case - today is Monday and I can see it on my list already.

Have I misunderstood this functionality?

The start date feature won't work because the lowest setting is 1 month.


This message was edited Mar 07, 2010.
roddyt

Posted: Mar 08, 2010
Score: 0 Reference
You missed the rest of the help message at the bottom of that section:
"Tasks that use a due-date modifier will not show up on your hotlist until they are due (unless they have a high enough priority). If you use a due-date modifier and the task is more than 1 week in the future, it will also be hidden from your other lists unless you turn on the "Show Due in the Future" filter. The exception is that even if you use a due-date modifier, tasks will not be hidden when in the "Due-Date" view, or when using the "Search" view to find future tasks."

In your last sentence, I think you're referring to the Hide Future Tasks setting. If so, that setting is for the Due date, not Start date. You can use the start date to effectively hide your task. If you set the Start date to the same Friday due date, then the task will be hidden until that day. The Start date repeats along with the due date, so you're not losing out there either.
PeterW 

Posted: Mar 08, 2010
Score: 0 Reference
Hi Roddy,

Thanks for the explanation. I did not notice the word "hotlist" when I read the help file. Duh!

However with regards to this bit:
Posted by roddyt:
In your last sentence, I think you're referring to the Hide Future Tasks setting. If so, that setting is for the Due date, not Start date. You can use the start date to effectively hide your task. If you set the Start date to the same Friday due date, then the task will be hidden until that day. The Start date repeats along with the due date, so you're not losing out there either.

That part is not working for me. The task is due every Friday so the next one is showing as being due on March 12. I have also set a start date of March 12. Yet the task remains visible today (Tuesday).

I am sure that this used to work for me. Is it working for anyone else?
Jake

Toodledo Admin
Posted: Mar 08, 2010
Score: 0 Reference
You should also pick a due-date modifier. "Due On" instead of "Due by".

http://www.toodledo.com/info/help.php?sel=42
PeterW 

Posted: Mar 08, 2010
Score: 0 Reference
Posted by Toodledo:
You should also pick a due-date modifier. "Due On" instead of "Due by".

http://www.toodledo.com/info/help.php?sel=42


Thanks, but I've tried this also and the task remains visible.
Jake

Toodledo Admin
Posted: Mar 08, 2010
Score: 0 Reference
Can you please create a support ticket and attach a screenshot of the page that shows the task that should be hidden? Please make sure that the current state of the filters is visible in the screenshot.

Thanks
PeterW 

Posted: Mar 08, 2010
Score: 0 Reference
Done - refer Ticket #7545.
roddyt

Posted: Mar 09, 2010
Score: 0 Reference
In your filter settings, are you hiding future tasks? The setting should read "Show Future Tasks." If it reads "Hide Future Tasks," you'll need to toggle it.

That's the only thing I can think of.
PeterW 

Posted: Mar 09, 2010
Score: 0 Reference
Posted by roddyt:
In your filter settings, are you hiding future tasks? The setting should read "Show Future Tasks." If it reads "Hide Future Tasks," you'll need to toggle it.

That's the only thing I can think of.

Hey Roddy,

Brilliant! That fixed it!

But I don't understand why. It almost seems the reverse of what I would expect. I tell Toodledo to show future tasks and it hides them? Seems like bizzaro world!

EDIT: I think I get it now. The option is what you want to change it to, not what it's currently set at. Guess is makes sense.


This message was edited Mar 09, 2010.
You cannot reply yet

U Back to topic home

R Post a reply

To participate in these forums, you must be signed in.