Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Questions

Email Notifications Lack UTF-8 Encoding Specification



AuthorMessage
AA

Posted: Sep 29, 2010
Score: 0



Hi,

Can you please add, to the header of every outgoing Toodledo email notification, the standard UTF-8 specification? It goes like this:

Content-Type: text/plain; charset="utf-8"

For those of us who use languages with diacritic letters in Toodledo, the email notifications are often garbled, displaying hieroglyphics instead of diacritic letters, unless you manually switch over to the UTF-8 encoding. But if you include the UTF-8 specification in the headers of all your emails, then everything will be displayed correctly quite automatically.

Thank you.


This message was edited Sep 29, 2010.
Jake

Toodledo Admin
Posted: Sep 29, 2010
Score: 0



Thanks for the bug report. We will look into it.
AA

Posted: Oct 16, 2010
Score: 0



Disappointing not to see this fixed in the October update. :-(

It's just adding 1 line to the header of every outgoing e-mail; I'm sure this would be a matter of seconds to fix.

Would appreciate it if I could avoid seeing garbled email notifications in future. Thank you!


This message was edited Oct 16, 2010.
Jake

Toodledo Admin
Posted: Oct 17, 2010
Score: 0



Its not as simple as it seems. Adding this header causes some other email clients to display incorrectly, in our tests. We are still trying to find a way to make this work for everyone.
AA

Posted: Oct 22, 2010
Score: 0



Thank you for the update. It's really strange that a standard UTF-8 header would cause the message to be displayed incorrectly for some users. :-o Employing standards, instead of workarounds, usually has the opposite effect. :-o

Right now, the email notifications only display properly for me if the email software implicitly assumes that the message is encoded in UTF-8. Both Gmail and iOS (iPad, iPhone) do that. But in my email software on my main Windows computer, Toodledo's email notifications are garbled, and they only display properly if I manually switch over to the UTF-8 encoding while viewing a Toodledo message.

The same email software works 100% OK with all kinds of other email notifications if these include the standard UTF-8 header. For example, I receive several daily email notifications from Google Calendar, and all of them are displayed properly because the headers in every message include the Content-Type: text/plain; charset=UTF-8 line.


This message was edited Oct 22, 2010.
Jake

Toodledo Admin
Posted: Oct 22, 2010
Score: 0



I think we may have figured it out. It was the quotes around "utf-8" that was causing the problem. If we send it as:

Content-Type: text/plain; charset=UTF-8

It seems to work better. We need to test it a little more, but I think this might be the solution.
AA

Posted: Oct 22, 2010
Score: 0



Thank you, that's interesting.

Google Calendar, Gmail, etc., does not use the quotation marks around "utf-8" (or other encodings), but standard email software such as Thunderbird does use them. :-o

(I know it's supposed to be better style to use quotation marks in such places in HTML as well, but it's not really important, of course... as long as the resulting email message isn't garbled.) :-)
AA

Posted: Oct 23, 2010
Score: 0



Many thanks, it's fixed now! Every letter, foreign or not, now displays perfectly as it should, thanks to the UTF-8 declaration as quoted by you in your latest message.

I have tested this on Windows XP (in the wonderful email client The Bat!), on iOS (both iPad & iPhone 4), in Gmail, and on Linux in 3 different webmail packages.

The result was almost 100% correct. The only flaw was in the email's Subject in Horde webmail on Linux. All letters in the body of the message are fine, but the Subject in Horde is garbled. That only applies to Horde; other webmail packages running on the same Linux server display both the Subject and the body of the messages correctly.

I know there is a way to specify encodings for email Subjects as well, in addition to specifying UTF-8 for the body of the email. Perhaps if you add the UTF-8 specification also for the email Subjects, then Horde webmail will get it right. (It's obvious that this is a flaw in Horde webmail now, perhaps in its configuration on the Linux server, rather than a Toodledo matter, but perhaps the flaw could be fixed easily for any Horde users, by specifying UTF-8 for email Subjects, too.)


This message was edited Oct 23, 2010.
Jake

Toodledo Admin
Posted: Oct 25, 2010
Score: 0



Encoding subjects is trickier. We'll look into it.
AA

Posted: Dec 09, 2010
Score: 0



Hello,

You have lost the UTF-8 specification in email reminders again. :( So, once again the text of all of Toodledo's email notifications is garbled for me, both in the body of the messages and in the Subject. The line specifying UTF-8 has simply vanished from the email headers. Please add it back. Thank you!

(PS: I'm aware of the recent problems with non-English characters in a preceding Toodledo version of the iOS app; I made sure not to upgrade to that particular version. Anyway, this seems unrelated, and leaving out the standard UTF-8 specification from email reminders can only make matters worse for everyone.)
Jake

Toodledo Admin
Posted: Dec 09, 2010
Score: 0



They were only removed for SMS messages that we send because Verizon and Sprint couldn't handle the extra mail headers. Regular emails that we send still have the UTF-8 headers. Please try switching your reminder from SMS to email and you will have the headers.
AA

Posted: Dec 10, 2010
Score: 0



Hi, unfortunately you're mistaken. You must have made an unintentional error and removed the UTF-8 specification from e-mails as well. I don't use reminders via SMS at all.

Another email reminder has just arrived, and it's garbled, both in the body of the message and in the Subject. There is no UTF-8 specification in the email's headers. I can paste the email's entire headers here if you wish; the email encoding specification has simply vanished, so that we're back to the state we were in many weeks ago when I first started this thread.

Please fix this. Thank you.


This message was edited Dec 10, 2010.
Jake

Toodledo Admin
Posted: Dec 10, 2010
Score: 0



I just tested email reminders with UTF-8 characters, and it works perfectly for me. Can you please check your reminder settings "Tools & Services" > "Alarms" and make sure that you aren't using SMS.
AA

Posted: Dec 14, 2010
Score: 0



Goodness... I really don't know how anyone could confuse emails with SMS. :-o

The good news is, the issue is fixed now. But it was definitely there a few days ago; the UTF-8 specification was missing from Toodledo's email reminders.

I have made a couple of screenshots for you, both from the same task, emailed to me on December 10th & December 14th. On December 10th, both the body of the message and the Subject field was garbled, due to the missing UTF-8 specification. Today in the same reminder and all others from the last few days, everything is fine.

* screenshot of email headers from December 10th: http://dl.dropbox.com/u/10440809/misc/Toodledo/email_reminder_header-2010-12-10.gif
* screenshot of email headers from December 14th: http://dl.dropbox.com/u/10440809/misc/Toodledo/email_reminder_header-2010-12-14.gif


This message was edited Dec 14, 2010.
Jake

Toodledo Admin
Posted: Dec 14, 2010
Score: 0



Im not really sure what was going on there, but I'm glad its working again.
You cannot reply yet


To participate in these forums, you must be signed in.



Toodledo Forums > Questions