Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Tips & Tricks

Outlook Integration Client in Beta



AuthorMessage
keef

Posted: May 01, 2008
Score: 0



Hi Eric,

Are you trying to use the tool from home or from work? You only usually need to use a proxy server if you are on a corporate network. It is very rare for a home network to have one.Unless you know for sure that you need to set a proxy server I'd uncheck the 'Use a Proxy Server' check box and test your account settings again.

Alternatively, you can use Internet Explorer to confirm what your proxy settings should be. Start IE and select Tools ->Internet Options->Connections->Lan Settings and see if any proxy settings are set there.

Hope that helps

Keith
sean.herschmiller

Posted: May 01, 2008
Score: 0



Keith,
Thank you very much for your work on the Outlook Sync app. I use it to transfer Toodledo tasks to my Blackberry. One question though. I had version .94 installed and then downloaded .95. When I uninstall through Control Panel and manually delete the folder I still get version .94 after installing the recently downloaded .95. Does .95 properly identify itself as such in the "About: section? Also, why do I get a security pop-up from Outlook that the Sync app is trying to access email addresses. I have to grant it access for 1min to allow a sync to happen. Obviously, this makes the auto sync unusable.
Thanks
Roman

Posted: May 01, 2008
Score: 0



Posted by sean.herschmiller:

Also, why do I get a security pop-up from Outlook that the Sync app is trying to access email addresses. I have to grant it access for 1min to allow a sync to happen. Obviously, this makes the auto sync unusable.
Thanks


i don´t think you can blame keith for outlook´s pain-in-he-hoop nagging security dialogues, can you? just spend aminute to google for ways to suppress this kind of warnings!

<edit> heck, it took me 30 secs to come up with this: http://www.contextmagic.com/express-clickyes/
@keith: maybe there´s a way to incorporate something like this into the plug-in itself?
</edit>


This message was edited May 01, 2008.
keef

Posted: May 01, 2008
Score: -1



Hi Sean,

Whoops. It seems that I forgot to update the version in the About page. I'll fix that soon.

As to the security box in Outlook, it is a well known Outlook problem that doesn't seem to have a simple solution. Microsoft have locked progressively locked down successive versions of Outlook to reduce its vulnerabilities to viruses. This makes the program more secure but unfortunately makes it near impossible to write external applications that work seamlessly with all versions.

So far I've encountered this issue on Windows Vista with a stand alone Outlook 2007 and on XP with Outlook 2003 connected to an Exchange server. What is your configuration?

I am still researching a fix for this issue, but there doesn't seem to be a simple answer. I agree that it makes the auto sync function useless in environments where it occurs, but please bear with me while I work this one out.

Cheers

Keith
keef

Posted: May 01, 2008
Score: 0




Posted by Roman:

i don´t think you can blame keith for outlook´s pain-in-he-hoop nagging security dialogues, can you? just spend aminute to google for ways to suppress this kind of warnings!


Thanks for that Roman. I will try and find a seamless way to fix this in the sync tool but in the mean time the tool you linked to could be a good solution.

I guess I should mention that you should only mess around with your Outlook security if you are sure that you have a good Anti-Virus solution - otherwise you could be opening yourself up for nasty surprises.


This message was edited May 01, 2008.
Scott

Posted: May 02, 2008
Score: 0



I have an issue w/ the sync and I couldn't find anything on your site or in this thread so... here goes.

I installed the application w/o any issue. I was able to do the authentication and configure the proxy and it appears to be OK. However, when I try to execute the script, I get the following error (from the trace log):

SyncApp.exe Error: 0 : Error during synchronization Object reference not set to an instance of an object.

Any idea what it could be?


This message was edited May 02, 2008.
keef

Posted: May 02, 2008
Score: 0



Hi Scott,
Seems like you've found a bug (sigh). Can you please mail me a copy of the complete trace? Mail email is developer(at)chromadrake.com

Do you have any contexts or folders set up?

Cheers
Keith
keef

Posted: May 03, 2008
Score: 0



I found a bug in the application where the synchronization would crash if you didn't have any folders defined. I've created a new release that fixes this issue and fixes some bugs on the first run screen.
Keith
eric.shotwell_1418060616

Posted: May 03, 2008
Score: 0



Hi Keith,

I investigated my problem by looking up the proxy info as you told me, and found no problems there, so I began looking at the problem from a different angle. I found that when I had copied my unique ID or pasted it in, I had inadvertently entered a space either before or after the ID, which was causing the authentication failure. Once I did that, I had a successful authentication and it is now synching. I will let you know if I have any feedback, and want to thank you for the support and for making this available extension freely available.

By the way, it would be great if someone could create a BlackBerry app that would do the same thing but synch specifically to a BlackBerry (which then, of course, would synch through the BES to Outlook over Exchange, for those who use Exchange and a BES). RememberTheMilk has an app called MilkSync that is useful for this.

(The good news, of course, is that one could probably use RememberTheMilk *and* Outlook *and* Toodledo now, since it's a full circle... Toodledo-->Outlook-->Blackberry-->RememberTheMilk-->Blackberry-->Outlook-->Toodledo)


This message was edited May 03, 2008.
eric.shotwell_1418060616

Posted: May 03, 2008
Score: 0



Posted by keef:
Are you trying to use the tool from home or from work? You only usually need to use a proxy server if you are on a corporate network. It is very rare for a home network to have one.Unless you know for sure that you need to set a proxy server I'd uncheck the 'Use a Proxy Server' check box and test your account settings again.

Alternatively, you can use Internet Explorer to confirm what your proxy settings should be. Start IE and select Tools ->Internet Options->Connections->Lan Settings and see if any proxy settings are set there.

Hi Keith,

I investigated my problem by looking up the proxy info as you told me, and found no problems there, so I began looking at the problem from a different angle. I found that when I had copied my unique ID or pasted it in, I had inadvertently entered a space either before or after the ID, which was causing the authentication failure. Once I did that, I had a successful authentication and it is now synching. So the error was actually mine, and nothing to do with your extension.

I will let you know if I have any feedback, and want to thank you for the support and for making this available extension freely available.

By the way, it would be great if someone could create a BlackBerry app that would do the same thing but synch specifically to a BlackBerry (which then, of course, would synch through the BES to Outlook over Exchange, for those who use Exchange and a BES). RememberTheMilk has an app called MilkSync that is useful for this.

(The good news, of course, is that one could probably use RememberTheMilk *and* Outlook *and* Toodledo now, since it's a full circle... Toodledo-->Outlook-->Blackberry-->MilkSync-->Outlook-->Toodledo) .

It's not a perfect solution, but at least it makes it easy to transfer tasks I've completed to and from Toodledo (even if it means using a 4th party app to get the job done currently).

Eric


This message was edited May 03, 2008.
keef

Posted: May 03, 2008
Score: 0



Thanks for the feedback, Eric - I am glad things started working for you.
A Blackberry sync client sounds like a good idea but I'm afraid I'll have to leave that for someone else to look at. The Outlook client is enough of a challenge for now :)
Keith
Scott

Posted: May 07, 2008
Score: 0



I downloaded the new version of the client and I'm still getting the same error (more or less)...

SyncApp.exe Error: 0 : Error during synchronization Object reference not set to an instance of an object.
at SynchLib.TaskItemProcessor.getFolderName(Int64 folderID)
at SynchLib.TaskItemProcessor.updateTaskItemFromTask(TaskItem taskItem, Task task)
at SynchLib.StateUpdatedOnToodleDo.Process()
at SynchLib.SyncContext.process()
at SynchLib.StateUpdatedOnBoth.Process()
at SynchLib.SyncContext.process()
at SynchLib.SyncTool.processContextStates(List`1 contexts)
at SynchLib.SyncTool.processContexts(List`1 contexts)
keef

Posted: May 08, 2008
Score: 0



Hi Scott, thanks for the response. Could you please mail me at developer(at)chromadrake.com and I'll try and work with you to resolve this.
Scott

Posted: May 08, 2008
Score: 0



Will do... Thanx.
keef

Posted: May 13, 2008
Score: 0



Hi Scott, I didn't end up getting an email from you. Did you solve the problem?
Scott

Posted: May 14, 2008
Score: 0



Nope, problem still exists, just got busy and couldn't work on it. I just sent you an e-mail w/ the full log.
keef

Posted: May 14, 2008
Score: 0



I've uploaded a new version of the client (0.97) to fix a couple of bugs. It's available at the usual place.

Please back up your tasks on Toodledo and Outlook before upgrading. Although I do test the code as much as possible, bugs can still creep in between versions (this is still beta software, m'kay?)

Cheers

Keith
mbkern

Posted: Aug 08, 2008
Score: 0



Hey Keith - I setup the sync yesterday, love it. I got it working with Toodledo and Outlook. But when I tried to open it today, it failed. I get the error:

Fatal error initializing user:Pbject reference not set to an instance of an object.

I've tried rebooting and restarting the program. When I open it with Outlook closed, it opens Outlook, and then crashes. If Outlook is already open, I get the crash immediately.

Thanks for the program!
gschimel

Posted: Aug 08, 2008
Score: 0



I set this all up earlier this week. Spent $10 to get the Todo app from Appigo for my Iphone. Set up an account with Toodledo and installed the Toodledo sync application from Chromadrake. All was going smoothly until today. Now the authentication is failing and it is all useless. Unless I can sync my Iphone tasks with Outlook, it is useless to me. I'd be willing to pay for the ability to sync, but I would like it to work. Anybody have another solution for this???
lwbates

Posted: Aug 08, 2008
Score: 0



I love this app and I've sent some $$ to help with the security issue. Serious thanks! I think the only thing I can't get it to do that I want, is that when I flag emails in outlook, outlook drops them into my tasks but those headings don't get synced. Any work around on this?
You cannot reply yet
Skip to Page:  1   2   3      Next


To participate in these forums, you must be signed in.



Toodledo Forums > Tips & Tricks