Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Developers

sync Authentication



AuthorMessage
reactor222

Posted: Oct 19, 2008
Score: 0



Keef,
I have (re)installed a few times. 0.9.9 will not complete initial authentication. I am using the correct toodledo ID and password, but the test fails. I am not firewalled. Any thoughts? Is anyone else having this same issue?
Thanks.

Ken.
keef

Posted: Oct 19, 2008
Score: 0



Do you have a proxy server, or have you changed the proxy settings?

Also, it is quite common to cut and paste an extra space or two when copying your account id from the Toodledo site.

keef
reactor222

Posted: Oct 19, 2008
Score: 0



I do not have a proxy server. I have copied and pasted, and retyped the account ID, both, with no success.

This message was edited Oct 19, 2008.
keef

Posted: Oct 20, 2008
Score: 0



There are two main reasons why authentication fails
1) The incorrects ID and password is being used
2) The client cannot connect to Toodledo to perform the authentication. This can be due to a firewall, proxy or network configuration issue.

Since you ahve eliminated option 1) it seems sensible to focus on option 2). I can't diagnose your network for you, but I can point you in the right direction

If you have a look at the syncapp.log file in the programs installation folder C:\program files\chromatic dragon\ToodledoSyncAPp this may give you a clue

Alternatively you can try downloading Fiddler, which will let you see the web traffic requests and responses being made by the client.

Finally, you may have a corrupt installation - did you remember to uninstall the old version before upgrading?

keef
reactor222

Posted: Oct 20, 2008
Score: 0



I am having no luck here.I have no installations of the App prior to 0.9.9 as I am a new user.
I have tried the client on three different machines, on three separate networks, and all fail to authenticate. Fiddler returns nothing useful, and the syncapp.log file is empty.
Could there be something amiss with my toodledo account? I have generated new IDs twice thinking something might be wrong in that regard, but no luck.

Thanks, Keef.

Ken.
reactor222

Posted: Oct 20, 2008
Score: 0



Keef,
I figured out the issue, and it may be something you wish to address in future releases of the App, or note somewhere in the release notes (maybe it's in there and I just missed it).

The App will not authenticate if the toodledo password contains special characters. My toodledo password includes single quotes. When I changed my password on toodledo to forgo the single quotes, the Sync App finally authenticated. SO while toodledo accepts any character in a password, the sync app does not.

Thanks, again, for your help.

Ken.
keef

Posted: Oct 21, 2008
Score: 0



Hi Ken,
thanks for that - I will definitely add this to to the bug list.

Thanks for your perseverance and for leeting me know the fix.

Cheers
keef
You cannot reply yet


To participate in these forums, you must be signed in.



Toodledo Forums > Developers

Contact Us | Blog | API | Jobs | Press | Documentation | Forums Privacy | Terms | Copyright © 2004-2014