Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Third-Party Applications

Sync to Outlook error in xml document (4267,8)



AuthorMessage
keith.cooper.fla

Posted: Aug 28, 2009
Score: 0



Hello, I been using the sync tool with Outlook since about February of this year with good results.

Recently I have been consistantly getting this xml document error. Can someone assist with this one? Is there bad data/characters within one of my tasks or is it something else????
Anders

Posted: Aug 28, 2009
Score: 0



It seems like that is likely. See the highlighted second post by the sync tool's developer in this thread: http://www.toodledo.com/forums/8/2060/-10064/read.html
keith.cooper.fla

Posted: Aug 29, 2009
Score: 0



Hello thanks for the reponse. Is xml file located on my machine somewhere to allow for me view that line or the text around that line item? There is not a lot of information in diagnostic tab leading me to the bad characters. I also have show traffic and trace output turned on.

The error message is "Error during synchonization: There is an error in XML document (4267,8)."
Anders

Posted: Aug 29, 2009
Score: 0



Did you do a manual sync after enabling show traffic and show trace? According to that post by Keef, you should be able to see the XML. By the way, make sure you read the correct post from that link. I realized it was somewhat confusing because I was referring to the second of the posts by keef, which is actually the fourth post in the thread.

This message was edited Aug 29, 2009.
keef

Posted: Aug 30, 2009
Score: 0



Just to add, the issue is mostly likely to be being caused by a task or note that you created/edited just before the problem occurred. Other users have fixed this issue by 'retracing' their steps and deleting the task notes for tasks that they modified jsut before the error started happening.

Not having an iPhone myself I have found it really hard to track down the root cause of this issue. Also, the offending characters get stripped out whenever someone mails me a trace.log :(

I plan to add an option to filter non-ascii characters to the next release. Hopefully that will fix the issue without messing things up for people who use extended character sets.

keef
keith.cooper.fla

Posted: Sep 21, 2009
Score: 0



Hello again, been traveling for work the past month and was not able to reply. I have posted one of my sync logs to the email address and was hoping to get some feedback.

This is all of the data that I received from the logs; I was hoping that I would see a bit more within the xml to assist in finding the task with the bad characters. Any thoughts? Thanks again for your help; I enjoy the app!!
keith.cooper.fla

Posted: Sep 21, 2009
Score: 0



ok; am I looking for a bad task that is currently within Toodledo (synced from my iPhone) or a bad task that is currently within Outlook?
You cannot reply yet


To participate in these forums, you must be signed in.



Toodledo Forums > Third-Party Applications