ForumsQuestionsIs the new interface laggy for everyone?


Is the new interface laggy for everyone?
Author Message
Wild Wonders

Posted: Mar 15, 2019
Score: 3 Reference
After yesterday's panic where the old interface was messed up, I tried out the "new" interface and found it to be unusable. I use the web interface both on a desktop computer and on an iPad through Safari. On the computer, clicking the box to mark an item complete was so slow. I could click and then count to two, sometimes 3, before the check mark would show up. On the iPad, the lag time was just as apparent *and* the site kept crashing. Is my experience typical? There's a lot of stuff I like about the new interface, but the lag time makes it completely unworkable for me and my team.
Anant G.

Toodledo Admin
Posted: Mar 15, 2019
Score: 0 Reference
Posted by Wild Wonders:
After yesterday's panic where the old interface was messed up, I tried out the "new" interface and found it to be unusable. I use the web interface both on a desktop computer and on an iPad through Safari. On the computer, clicking the box to mark an item complete was so slow. I could click and then count to two, sometimes 3, before the check mark would show up. On the iPad, the lag time was just as apparent *and* the site kept crashing. Is my experience typical? There's a lot of stuff I like about the new interface, but the lag time makes it completely unworkable for me and my team.


Hi, Can you create a video and put it in a support ticket please. We will be able to debug from there.

Thanks
Ob-La-Di+ruben

Posted: Mar 24, 2019
Score: 1 Reference
I find the new interface laggy too.

I switched from the legacy interface recently because the tags cloud started showing up in reverse alphabetical order in the legacy tags list.

There's lots of new features in the new UI but it would be nice if response time hadn't seemed to have crept up so much.

My current example is setting a date on a task. I can count a good couple seconds every time I set a date in the new UI before I can get the time/date dialog window to disappear. I just tried it in the legacy UI and it goes away seemingly instantaneously. It's a bother.

Are others seeing that too?


This message was edited Mar 24, 2019.
david.askew

Posted: Mar 25, 2019
Score: 2 Reference
New task interface is definitely laggy compared to the old one. I switched from old to new recently when the old interface was hit with the "refresh on task completion bug" ...

This message was edited Mar 25, 2019.
Anant G.

Toodledo Admin
Posted: Mar 25, 2019
Score: 1 Reference
Posted by rubenB:
I find the new interface laggy too.

I switched from the legacy interface recently because the tags cloud started showing up in reverse alphabetical order in the legacy tags list.

There's lots of new features in the new UI but it would be nice if response time hadn't seemed to have crept up so much.

My current example is setting a date on a task. I can count a good couple seconds every time I set a date in the new UI before I can get the time/date dialog window to disappear. I just tried it in the legacy UI and it goes away seemingly instantaneously. It's a bother.

Are others seeing that too?


Posted by david.askew:
Jew task interface is definitely laggy compared to the old one. I switched from old to new recently when the old interface was hit with the "refresh on task completion bug" ...



Hi, can you guys create a support ticket for the same so that we can track what's wrong.

Thanks
david.askew

Posted: Mar 25, 2019
Score: 0 Reference
I've already opened my 1 support ticket today .. for the stupid new batch edit feature.
Ob-La-Di+ruben

Posted: Mar 26, 2019
Score: 0 Reference
Filed support ticket 72787 for this, as you requested, Anant.

https://www.toodledo.com/info/ticket.php?view=72787

The avi video I made with CamStudio to demonstrate by comparing new UI and legacy UI does not show the clearly slower new UI clearly at all, and actually, during playback, makes the legacy UI even appear sluggish when the due date dialog disappears instantaneously there.

Since the avi video ended up being 26.7 meg in size, the upload failed and I didn't bother making another video since it didn't demonstrate the problem clearly anyways. Let me know if you want me to.
Ob-La-Di+ruben

Posted: Mar 28, 2019
Score: 1 Reference
I also see basically the same increased laggy-ness contrast between new UI and legacy when getting out of the task tag cloud dialog.

New UI is way, way slower, bothersomely so. Legacy response is almost instantaneous
CharleneTX

Posted: Mar 29, 2019
Score: 3 Reference
The current version is almost unusable it's so slow. Trying to click the right spot to change a date or priority takes multiple tries. I have no idea how to capture a video of it.
paul_1351977321

Posted: Mar 30, 2019
Score: 2 Reference
Toodledo does not respond to clicks fairly regularly now. Here is a video showing me clicking on most of the elements of the top two to do's. Once I refresh Firefox, Toodledo comes back to life (for a little while) and responds to new clicks. I will figure out how to add a video for your viewing pleasure.

This message was edited Mar 30, 2019.
Ob-La-Di+ruben

Posted: Mar 30, 2019
Score: 1 Reference
Yesterday I ran into a situation where certain tasks would not respond to clicks on the drop-down menu icon to create-subtasks/clone/etc. It only happened with one or two tasks and not any of the others. Reloading the toodledo page did not fix it. Switching browsers worked tho.

It was very aggravating but I couldn't nail down any specific info on how this was occurring to share with Toodle.


This message was edited Mar 30, 2019.
jeff

Posted: Mar 31, 2019
Score: 1 Reference
Posted by paul_1351977321:
Toodledo does not respond to clicks fairly regularly now. Here is a video showing me clicking on most of the elements of the top two to do's. Once I refresh Firefox, Toodledo comes back to life (for a little while) and responds to new clicks. I will figure out how to add a video for your viewing pleasure.


I have the same problem in Safari. Toodledo has become unusable for me. I can do a fresh restart of the entire computer or browser and hit the same problem each time. I can add items, but if I try to set or change a date the browser will hang (latest Safari on MacOS)

It's been happening for a bit for a few weeks or months, but in the past couple of days it has become unusable.

It used to be the case I would have to wait a couple minutes and then I could change dates in the browser (as if something was loading behind the scenes) but now it just doesn't seem to work. Spinning beachball of death every time.
apois

Posted: Apr 01, 2019
Score: 2 Reference
Yes - I'm getting frustrated by the lag as well. The old interface was great - click on the date and the date picker would appear immediately, and I seem to remember selecting a date would close it immediately as well. This was a great time saver!

Now clicking on a date seems to incur a lag *before* the datepicker animation even starts to open. Then there is another lag when closing.

Please:
* remove the lag when clicking
* provide an option to disable unnecessary animations
Anant G.

Toodledo Admin
Posted: Apr 01, 2019
Score: 1 Reference
Posted by jeff:
Posted by paul_1351977321:
Toodledo does not respond to clicks fairly regularly now. Here is a video showing me clicking on most of the elements of the top two to do's. Once I refresh Firefox, Toodledo comes back to life (for a little while) and responds to new clicks. I will figure out how to add a video for your viewing pleasure.


I have the same problem in Safari. Toodledo has become unusable for me. I can do a fresh restart of the entire computer or browser and hit the same problem each time. I can add items, but if I try to set or change a date the browser will hang (latest Safari on MacOS)

It's been happening for a bit for a few weeks or months, but in the past couple of days it has become unusable.

It used to be the case I would have to wait a couple minutes and then I could change dates in the browser (as if something was loading behind the scenes) but now it just doesn't seem to work. Spinning beachball of death every time.



Posted by apois:
Yes - I'm getting frustrated by the lag as well. The old interface was great - click on the date and the date picker would appear immediately, and I seem to remember selecting a date would close it immediately as well. This was a great time saver!

Now clicking on a date seems to incur a lag *before* the datepicker animation even starts to open. Then there is another lag when closing.

Please:
* remove the lag when clicking
* provide an option to disable unnecessary animations



We are looking into the lag issues right now. In next couple of days we will be testing it on beta and see how much we can improve on the query time. Also we will be doing fixes on new tasks version first and make it stable and then come to the legacy version.

Thanks
Ob-La-Di+ruben

Posted: Apr 06, 2019
Score: 0 Reference
Posted by Wild Wonders: - March 15
On the computer, clicking the box to mark an item complete was so slow. I could click and then count to two, sometimes 3, before the check mark would show up. On the iPad, the lag time was just as apparent *and* the site kept crashing. Is my experience typical? There's a lot of stuff I like about the new interface, but the lag time makes it completely unworkable for me and my team.

I never saw this lag before when it was originally posted, but today it's started appearing for me too. Check off as completed used to be instantaneous (in new UI) but now I can also count to about past 2 before it completes. (May not have checked off any tasks in last day or so, so can't say exactly when it started appearing)
Ob-La-Di+ruben

Posted: Apr 06, 2019
Score: 1 Reference
Also, to "apois" or anyone -

Toodledo responded on my ticket about laggy dismissal of date dialog and tags dialog windows with a request for me to try out some of their latest changes (about a week ago) and to see if it had gotten better. (They didn't specify whether the changes were in beta or prod but I checked both).

I didn't see any improvement. I don't know if anyone else sees differently. In fact, in beta, there seemed to be an even longer lag, at times, than before but after a few cycles thru the dialogs on different tasks, it appeared to speed up to the same slowness level of prod.
-J-O-D-

Posted: Apr 06, 2019
Score: 0 Reference
Hm, that' strange. Right now, I can complete a task imediately, and even setting a date via date picker is at once, no 1-2 seconds waiting for the picker to disappear - Chrome, Saturday, evening.
Ob-La-Di+ruben

Posted: Apr 06, 2019
Score: 1 Reference
Posted by -J-O-D-:
Hm, that' strange. Right now, I can complete a task imediately, and even setting a date via date picker is at once, no 1-2 seconds waiting for the picker to disappear - Chrome, Saturday, evening.


Hmm - you're right. The bad lag on checking off tasks has gone away (not instantaneous like legacy but is quick); I guess that was a temporary thing; had never seen it in all my years on TD before today. Still a bit of a delay in unchecking (more than legacy UI), but oh well.

Still see the same date picker lag as always, though. Definitely more than a second+ tho possibly a bit less than 2. (Can count slowly to 2+ but my iterations are less than a second each, i think)
projectBlake

Posted: Apr 06, 2019
Score: 1 Reference
I'm seeing the lagging as well, with the most frustrating part being the tag cloud. clicking to bring it up gives me an out of focus version that takes a moment to fully appear. So so so miss the old tag cloud.
-J-O-D-

Posted: Apr 07, 2019
Score: 0 Reference
Then I don't know - see this (recorded 15 minutes ago): https://1drv.ms/v/s!AlER-iHBX0Pjh-9DtcOyqO3qpdpKYw .

EDIT: I mean, for me this is not laggy. But my opinion may be biased.


This message was edited Apr 07, 2019.
You cannot reply yet

U Back to topic home

R Post a reply

Skip to Page:  1   2      Next

To participate in these forums, you must be signed in.