ForumsNewsToodledo Tasks redesign ready for public beta testing


Toodledo Tasks redesign ready for public beta testing
Author Message
Jake

Toodledo Admin
Posted: Jan 20, 2017
Score: 0 Reference
If you have many saved searches and many tasks, we have discovered that this causes the badges (the counters next to each saved search that say how many tasks are inside) to take a long time to calculate and this slows down the page loading. Salgud, I think this is why your custom hotlist is loading slower. A quick fix would be to disable the badges on saved search like it is now on the current site, but we don't really want to do this. We have some ideas to speed this up and will get it working faster one way or another.
ChristianDiscer

Posted: Jan 20, 2017
Score: 1 Reference
One thought about the tasks display; When a field (like due date, tag, etc) is not set to a value then nothing should display, that is it should not display "No Due Date" or "No Tags". Maybe a user defined setting to choose what is displayed; blank, no ..., a special character (like a single middle dot), or your own defined text.

Currently when I review the list my eyes seem to gravitate to the "No ..." text items.

Thanks
FHE-IV

Posted: Jan 20, 2017
Score: 0 Reference
Posted by Adrien Beau:
Saved searches all show up here. They work just fine (and much faster than before).



Opps! Sorry, I meant to say that my saved searches DO show up, but the tasks do not load.
Salgud

Posted: Jan 20, 2017
Score: 0 Reference
Posted by Jake:
If you have many saved searches and many tasks, we have discovered that this causes the badges (the counters next to each saved search that say how many tasks are inside) to take a long time to calculate and this slows down the page loading. Salgud, I think this is why your custom hotlist is loading slower. A quick fix would be to disable the badges on saved search like it is now on the current site, but we don't really want to do this. We have some ideas to speed this up and will get it working faster one way or another.


Almost 2200 tasks (only 170+ active), 35 Saved Searches. I guess that probably qualifies. I turned off the counts, didn't seem to make much difference. It is usable as is. I seldom pay attention to the counts, so I won't miss them.
pawelkaleta

Posted: Jan 21, 2017
Score: 2 Reference
Posted by pawelkaleta:
Each time I pick a date from any date selector (e.g. for Start Date or Due Date etc.) I need to wait for 2-3 seconds until selector disappear and date is set for task. It is pretty anoying and it doesn't work like this in non-newbeta layout where it happens immadiately after clicking on given date.

Does any of you experience the same issue?


I have started to use tags again and have noticed similar issue in tags selector as well, i.e. it takes ca. 2-3 seconds until the tags I've just chosen are "accepted" after I take mouse pointer out of tags selector area and only then the tag selector disappears.

For comparison, when I change status or folder or priority or context, then the interface reacts immediately, as it should. Is it intended to work like this for dates and tags?
FHE-IV

Posted: Jan 22, 2017
Score: 0 Reference
Posted by FHE-IV:
Posted by Adrien Beau:
Saved searches all show up here. They work just fine (and much faster than before).



Opps! Sorry, I meant to say that my saved searches DO show up, but the tasks do not load.



FYI...

It appears that if I create new SAVED SEARCHES on the new version of the page the tasks AND the number appear. The search was almost instantaneous. If I had to do that I would.
Martys To Do

Posted: Jan 22, 2017
Score: 0 Reference
I have an "optionally on" due date modifier with a task repeating daily. When I complete the task, it rolls over to the next day on the main website, but does not seem to rollover on the beta site.
Gnopps

Posted: Jan 23, 2017
Score: 0 Reference
The repeat dialouge always closes itself for me the first time I open it. Steps to reproduce:

1. Create a new task using quick add
2. Click on the repeat-box to open window for repeat
3. Click anywhere in the repeat-window
4. Windows closes itself with no selection being made
5. Now when you repeat form step 2 the problem does not occur and you can make changes as normal

This happens to me to all new tasks. I'm using Firefox 50.1.0 on Win10.
Jake

Toodledo Admin
Posted: Jan 23, 2017
Score: 0 Reference
@FHE-IV: Can you please create a support ticket so that we can figure out why your saved searches are showing empty on the new tasks section? We haven't seen this before.

@Martys To Do: Did you refresh the page or reload the list? This should have caused the tasks to update.

@Gnopps: Thanks for the bug report. I see what the problem is and will work on a fix.

@salgud: We found the bottleneck in the saved search calculations and fixed it. Saved searches should load much much faster now.


This message was edited Jan 23, 2017.
Christoph Dollis

Posted: Jan 24, 2017
Score: 0 Reference
Saved Searches now work as expected on the Beta Android app, after the most recent update.

Thanks Jake and Toodledo team!
Christoph Dollis

Posted: Jan 24, 2017
Score: 0 Reference
A quick heads up to everyone. I went here last night:

https://tasks.toodledo.com
(the new beta tasks new layout)

... and added a few tasks using the multi-add feature. That worked, but all my other tasks were then deleted everywhere (in the new beta tasks new layout view, old tasks layout and view, mobile apps, etc.). I created a ticket about this, but, to say the least, the warning about making a backup of your data before using the beta is something I would take seriously.

Fortunately, I was able to restore most of my tasks from a week-old backup. I also restored my remaining tasks from the Deleted Tasks page, where it said my tasks were deleted after I clicked on the Trash icon (which I did not).


This message was edited Jan 24, 2017.
tomcal

Posted: Jan 25, 2017
Score: 0 Reference
I use Toggl to track my tasks and it works great with the "Old" task layout. The new one doesn't show the Toggl button. Is there anything I can do to get that working again?
Purveyor

Posted: Jan 25, 2017
Score: -1 Reference
n.m.

This message was edited Jan 25, 2017.
Salgud

Posted: Jan 25, 2017
Score: 1 Reference
Thanks, Christoph. I was about to switch over myself, but I think I'll wait a bit longer.
Jake

Toodledo Admin
Posted: Jan 25, 2017
Score: 0 Reference
I believe that we have fixed the bug that caused Christoph's issue. It was a multi-edit gone bad. We have added extra checks and warnings now, so it shouldnt happen again.
Christoph Dollis

Posted: Jan 25, 2017
Score: 0 Reference
Posted by Jake:
I believe that we have fixed the bug that caused Christoph's issue. It was a multi-edit gone bad. We have added extra checks and warnings now, so it shouldnt happen again.


Sounds about right.
Christoph Dollis

Posted: Jan 25, 2017
Score: 0 Reference
Dear Toodledo Team,

This is a feature suggestion and not an urgent problem.

If you'll look at the two screenshots I'm linking, you'll see that when Multi-Line view is selected in the old stable web app and sorting is done first by folder, there is enough space to read longish folder names:

https://goo.gl/photos/Q1Mx9nkFankjgxJC6

However, in the beta new layout, these same folder names (or whatever the first sort criteria is) are truncated:

https://goo.gl/photos/2ZGHLpw4WdDZC4gFA

Visually, this is not as appealing, and I think it would be good if there was at least as many characters allowed for this in the beta new layout as there is in the old stable web app.

Now if this absolutely isn't possible to have more characters than you've allocated because of fluid layouts or similar considerations, I get that. However, if it is possible to allow more room for the first sort criteria names here, that would be excellent. Because there is so much room for the Task Title in the Multi-Line view, that there should be enough space, all else being equal.

The old presentation of this is better than the new presentation. You'll see what I'm getting at when you look on the top right of these screenshots—the part I've marked off in red.

Cheers,

Christoph


This message was edited Jan 25, 2017.
Christoph Dollis

Posted: Jan 26, 2017
Score: 0 Reference
Salgud, I think it will be OK to switch over now.

What happened, I'm sure, is that I meant to do a multi-edit on all my old tasks to change the start date, but had accidentally clicked the delete switch first. Then I unclicked the delete switch, visually clearing that, made the change to the start date, then pressed save.

There was a bug where, unbeknownst to me, the delete switch was still selected, but not visible. However, Jake quashed that bug and it shouldn't be a problem anymore. I now personally feel confident that when making a multi-edit, my tasks will not be deleted.

Definitely back up, however. It's good practice when testing Beta software, and recommended.
Martys To Do

Posted: Jan 27, 2017
Score: 1 Reference
Posted by Jake:
.

@Martys To Do: Did you refresh the page or reload the list? This should have caused the tasks to update..


Yes, I did refresh.
When I looked again about an hour later, it was listed properly. (Using Edge)
majesticthrust

Posted: Feb 01, 2017
Score: 0 Reference
I've just tried to view all tasks with a tag with slash "/" in it and the webapp hang.
There is an error in console too:

scripts.09e9b036.js:46 Uncaught RangeError: Maximum call stack size exceeded
at JSON.stringify (<anonymous>)
at Object.shouldComponentUpdate (scripts.09e9b036.js:46)
at c.updateComponent (common.5cd77c20.js:78)
at c.receiveComponent (common.5cd77c20.js:78)
at Object.receiveComponent (common.5cd77c20.js:7)
at Object.updateChildren (common.5cd77c20.js:78)
at _reconcilerUpdateChildren (common.5cd77c20.js:79)
at _updateChildren (common.5cd77c20.js:79)
at _.updateChildren (common.5cd77c20.js:79)
at _updateDOMChildren (common.5cd77c20.js:79)
at _.updateComponent (common.5cd77c20.js:79)
at _.receiveComponent (common.5cd77c20.js:79)
at Object.receiveComponent (common.5cd77c20.js:7)
You cannot reply yet

U Back to topic home

R Post a reply

Skip to Page:  1   2   3   4   5   6   7   8      Next

To participate in these forums, you must be signed in.