Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Questions

setting custom due date



AuthorMessage
gjblair

Posted: Feb 28, 2013
Score: 0



Until the recent release a day or 2 ago, when I wanted to set a custom due date for a task, it would first bring up the calendar-by-month-at-a-time, and I could then use the calendar wheel if I wanted to. Now, it brings up the calendar wheel first, which is what I want a much smaller percentage of the time. Is this the only behavior possible, or I am missing an option setting that would bring up the month-at-a-time tool first?

-Gary

Oh, forgot to say that this is specifically on the iPad.


This message was edited Feb 28, 2013.
Jake

Toodledo Admin
Posted: Feb 28, 2013
Score: 0



When you are looking at the wheels, there is a button in the corner to switch to the calendar. It will then remember your choice and show the calendar the next time.
pjlewis

Posted: Mar 01, 2013
Score: 0



Hi Jake,

I noticed this behaviour too on the Ipad. It does not appear to remember the setting, instead always defaulting to the wheel. Very annoying.

Phil.
Jake

Toodledo Admin
Posted: Mar 04, 2013
Score: 0



I will look into this. You may need to select a date from the calendar before it will remember to always show the calendar.
gjblair

Posted: Mar 05, 2013
Score: -1



It seemed to be working for a while, and today it was again starting with the wheel each time I set a custom due date. I did not update anything since my initial post. It might be useful to have a setting that indicated which mechanism is the default. And it does not appear possible to actual CHOOSE a date with the wheel - you seem to have to go into the calendar anyway to actually select the date.

-Gary
gjblair

Posted: Mar 13, 2013
Score: -1



I downloaded the update that loads the task list more efficiently, and now the behavior I described in my 2/28 post exists again. If I choose a custom due date, I get the wheel, but I can select the calendar. But I must do that EACH time, even if for the same task. And I JUST VERIFIED that behavior is as I am describing. PLEASE provide an option to specify which method to use as the default. I have to forward items A LOT, and each extra screen-touch costs time.
pjlewis

Posted: Mar 14, 2013
Score: 0



This is still not working for me either.

What did your investigations reveal Jake?
Jake

Toodledo Admin
Posted: Mar 14, 2013
Score: 0



I have not been able to reproduce the problem, but it is still on my to-do list to keep trying.
pjlewis

Posted: Mar 14, 2013
Score: 0



Just in case we're not looking at the same thing, I can reproduce this on my iPad with the latest Toodledo and iOS versions as follows:

1. Select a task
2. Toodledo displays the task detail in the right hand panel
3. Select due date. The edit due date dialogue appears with a list of dates and options at top for none and custom.
4. Select custom. The wheel interface is shown.
5. Select the calendar icon. The calendar date selector is shown.
6. Pick a date. The due date is changed to the selected date.
7. Repeat above with another task. It s expected that the calendar date selector is shown at step 4. Instead, the wheel interface is always shown.

A similar effect is seen on the start date as well.
Jake

Toodledo Admin
Posted: Mar 14, 2013
Score: 0



When I do this, I get the calendar every time, so there is something else in play here. We are investigating.
pjlewis

Posted: Mar 15, 2013
Score: 0



Thanks for checking Jake. This is a curious one! Let me know if you need me to check or try anything.
gjblair

Posted: Apr 09, 2013
Score: 0



This is still troublesome. I am running v3.0.4 on 2 iPads.
It is working fine on my personal iPad, but still having the problem on my work iPad.
A difference is that security settings on the work iPad are pretty tight, and it has the GOOD app installed.
Otherwise, I can find no setting differences that might explain the problem.
It is still very annoying...
JPR

Posted: Apr 10, 2013
Score: 0



I know one possible solution: code the app to show the calendar on the first tap and get rid of the list style picker entirely. Way more efficient IMHO.
gjblair

Posted: Apr 10, 2013
Score: 0



There are times when the calendar wheel is useful.
However, if I use the wheel to set the m-d-y, HOW DO I ACTUALLY CHOOSE THAT AS THE DUE DATE?
None of the controls on the wheel appear to do that.
I STILL have to select the calendar-by-month in the lower right of the wheel and then touch the date I actually want.
What am I missing, or is the wheel actually that brain-dead?
Jake

Toodledo Admin
Posted: Apr 10, 2013
Score: 0



This bug will be fixed in the next update. It appears that if the iPad is in landscape mode, it will open it in the wheels always.
gjblair

Posted: Apr 11, 2013
Score: 0



Thanks, that tracks with my usage. I tend to use my personal iPad in portrait orientation most of the time, but use my work iPad in landscape much more frequently because I use a Bluetooth keyboard with it most of the time.

The old programmer in me just loves phase-of-the-moon type bugs like that...

Is there an answer to my question 2 posts back (on 4/10)?
JPR

Posted: Apr 11, 2013
Score: 0



Posted by gjblair:
There are times when the calendar wheel is useful....


Agreed. I would prefer the first tap on Due Date opens the "custom" picker, wheel or calendar... and then just get rid of the list picker altogether. Would need to add a "None" option to the calendar and wheel pickers.
You cannot reply yet


To participate in these forums, you must be signed in.



Toodledo Forums > Questions

Contact Us | Blog | API | Jobs | Press | Documentation | Forums Privacy | Terms | Copyright © 2004-2014