Legend

Forum

Unread topics or posts

Topic

Unread posts

Locked

Announcement

Forums > Questions

How do I import into Notebook?



AuthorMessage
Jake

Toodledo Admin
Posted: Sep 26, 2008
Score: 0



A .pwi file is a proprietary Microsoft file format that we don't know how to read. Hopefully Microsoft has provided some way to convert this to an industry standard CSV file. We are not familiar with Windows Mobile, but look in you menus for an export option. Or maybe try importing the PWI file into Excel and then export it back out again.

Hope that helps.
jhsidoc

Posted: Sep 26, 2008
Score: 0



Ok, so once I figure out how to open them I would import them back into excel. Do I need to then have each not as a field in excel or each note as a separate excel file?
J-Mac

Posted: Sep 27, 2008
Score: 0



WM5 or WM6? On your PC, XP or Vista?

Vista's WMDC is terrible and cannot convert WM files - a glaring but typical oversight by Microsoft, unfortunately.

But there is a workaround: Do not double-click on the file and also do not right-click on it and use "Open with..." Word. Instead, open Word - preferably Word 2003 - and then click File>Open and browse to the .pwi file or files and open it that way. Word should then convert it to a text file. That should be able to be imported to the Toodledo notebook. If not, try "Rename" (after getting it into a text file) and change the extension from .txt to .csv.

Or if you are running XP on your PC, then simply sync the .pwi using Activesync. Activesync has a built-in converter that will change the .pwi files to either .doc or .txt files.

HTH!

Jim

If you are using
jebanks

Posted: Sep 30, 2008
Score: 0



I'm having a terrible time trying to get my notes out of Mac Entourage and into the Toodledo Notebook, and I'm hoping someone has some suggestions or help.

I'm using the Export-Import Entourage 1.3.10 Applescripts to export notes out of Entourage. (It's the only way to export notes from Entourage in a useable file.) These scripts export notes as Tab-delimited. You're supposed to be able to open the resulting text file in Excel and resave it as a CSV, which is the format that Toodledo requires.

The problem is that most of my hundreds of notes have carriage returns in them. The Applescripts replace these CRs with a graphic version of a paragraph symbol, not real line breaks or paragraph marks. There is no way to do a search and replace on these symbols in Excel--that can only be done in Word. (There is a specific script in the bundle that is supposed to take care of this problem, but it chokes after fixing only a handful of rows in the Excel sheet, leaving the majority with the paragraph symbols in. The Export-Import developer is MIA-- I have written to him twice in the last several weeks and gotten no response.)

Well, if I copy the data out of Excel and paste it into a Word doc, I get a table with the same structure as the cells I copied out of Excel. I can then search and replace the paragraph symbols with line breaks or paragraph marks. But then, when I try to paste the Word table back into the equivalent cells in Excel, every line break WITHIN a cell splits off a separate cell, thus ruining the entire structure and making it unuseable for import.

The only solution I see thus far is to individually edit the content of the notes in Excel, manually replacing the paragraph symbols with line breaks that don't split the cells, and then saving the workbook as a CSV. I've tried that, and it works, and imports to Toodledo properly. But I don't have time to manually edit the contents of nearly 400 notes.

I've also tried to edit Tab-delimited and CSV files by opening them directly in Word as text files and then doing search-replace. But then, Excel interprets each line break in the CSV file as a new row, creating another chaotic, unuseable file.

Anyone have any ideas? Is there a Mac text editor with search and replace, for instance, which can work on CSV files? Or any other thoughts? Any help is appreciated!

p.s. I thought the other solution might be to disable Entourage syncing with my old Palm Treo, then overwrite the Palm memos from the Treo into Palm desktop. But Palm desktop on the Mac apparently only exports as Tab-delimited, which Toodledo can't import, and the resultant files also have the paragraph symbols in them.
Jake

Toodledo Admin
Posted: Sep 30, 2008
Score: 0



That certainly sounds like a tricky problem. I can't guarantee that this will work because I haven't tried it, but I would try using a text editor other than Word, since Word often does some automatic formatting that you don't want to happen. You could try Apple's TextEdit, or you could download something like Text Wrangler.

Also, I would use Excel to convert it to a CSV file before I tried to convert the funky characters back to line breaks.

Good luck!
jebanks

Posted: Oct 02, 2008
Score: 0



OK, after much brain-racking, trial-and-erroring-ing and Googling, I have found a workable solution to my Mac Entourage Note export/Toodledo Notebook import problems. (See my previous message for a description of the problem.)

As suggested, I downloaded TextWrangler for the Mac in order to attempt to replace the paragraph gremlins with actual character returns/line breaks in the CSV file. The problem is, CSV interprets every line break as a new record, thus throwing the whole CSV file out of whack.

After trying to fix this every which way, I finally stumbled across the Wikipedia entry on CSV files. The problem lies here: the specification for CSV says that "fields with embedded line breaks must be delimited by double-quote characters."

So, I went back to the CSV file in Excel, and put quote marks at the beginning and end of the contents of each cell containing note body text. I then re-saved the CSV file and opened it in TextWrangler, and replaced the paragraph gremlins with line breaks. Then I uploaded the CSV to Toodledo.

Lo and behold, this time it worked. I uploaded about a hundred notes, and each one uploaded properly, with the line breaks within the note bodies being respected. The only issue is that all of my notes have quotes at the beginning and end, but this is only a very minor annoyance. Typing in the quotes was much, much less tedious than trying to manually fix the line breaks in Excel would have been.

A couple of things I encountered working in Excel: putting quotes around email addresses and URLs in Excel turns them into hyperlinks. If you don't want this to happen, type an extra space between the quote and the text, both at the beginning and end.

Also, I'll mention that the above procedure seems like it would work for exporting notes from Palm Desktop on the Mac, too, because the version I have only exports as teb-delimited, and it puts in paragraph gremlins instead of line breaks, just like the Export-Import Entourage Applescripts.

Anyway, I hope this helps someone else!

Posted by Toodledo:
That certainly sounds like a tricky problem. I can't guarantee that this will work because I haven't tried it, but I would try using a text editor other than Word, since Word often does some automatic formatting that you don't want to happen. You could try Apple's TextEdit, or you could download something like Text Wrangler.

Also, I would use Excel to convert it to a CSV file before I tried to convert the funky characters back to line breaks.

Good luck!
Jake

Toodledo Admin
Posted: Oct 02, 2008
Score: 0



I am glad that you got it to work, and thanks for sharing your results with the rest of us.
DavidKoch

Posted: Oct 17, 2008
Score: 0



Hello,
i tried to import my notes from Outlook 2003 into the Toodledo Notebook using the CSV import. There seem to be some problems regarding german umlauts. It seems that the importer stops interpreting the input line when it encounters non-standard ASCII characters, so the imported note gets truncated. I then tried to import a UTF-8 encoded CSV. In this case the imported note is complete but the umlauts get corrupted. At last I converted the umlauts to HTML (i.e. *ampersand*uuml; *ampersand*szlig;). While this worked fine for the note itself these sequences appear uninterpreted in the title line.
Please note that the problem with UTF-8 encoded CSV also exists when you try to reimport notes to Toodledo which were previously exported from Toodledo to CSV.

Although this can be solved by some search and replace commands this obviously is a bug which should be solved.

Thanks for your great service, David


This message was edited Oct 17, 2008.
Jake

Toodledo Admin
Posted: Oct 17, 2008
Score: 0



Thanks for the bug report.
You cannot reply yet
Skip to Page:  1   2  


To participate in these forums, you must be signed in.



Toodledo Forums > Questions

Contact Us | Blog | API | Jobs | Press | Documentation | Forums Privacy | Terms | Copyright © 2004-2014