Unread topics or posts


Unread posts



Forums > Third-Party Applications

Appigo Todo - Toodledo Sync Issue


Posted: Jun 11, 2009
Score: -1

Funny thing happened this morning. The toodledo's context page (only the context page) was dead for me. Later, it worked fine after some hours. I don't know why this ever happened.

May be Toodledo Issue:

One more thing I noticed - When I used my broadband wifi in my iphone and do a "Perform Full Sync" with Appigo Todo, I got the following error (in the sync log) stating:

Syncing Contexts
parseXMLFileAtURL returned error: lost network connection
syncContexts - no contexts found on server
SyncTasksToServer found 455 local tasks needing sync
parseXMLFileAtURL returned error: lost network connection
Failed to update Task on server: ************** (task name)
... (the above error repeated for a couple of tasks)

Okay, the above issue is when I do a full sync from appigo todo with wifi connection in my iphone. This issue was there for quite a long time, i didn't care to post it to either appigo todo or toodledo, since the sync was perfect when I used 3G instead of wifi. I have reasons to believe this issue is toodledo based becoz, i got a similar error log when I used the ToodledoSync application (in an entirely different broadband connection and on the desktop, not in my iphone!) and the error log was specific to Context and losing connection.

May be Appigo Todo Issue:

But from today morning, when I used 3G and did the perform full sync from appigo todo, I'm getting the following error in the sync log

SyncTasksToServer found 455 local tasks needing sync
Error editing tasks: Invalid Parent
Failed to update Task on server: ******* (taskname)
(the above last two lines repeated for some tasks before it ended)

I'm posting this to both Appigo todo and Toodledo's forums, since the losing connection and context issue may be toodledo based, but the later issue is of course appigo todo based or may be both have something to contribute.

I can clearly see that Appigo todo's Sync is trying to do the most stupid thing - try to sync the subtasks before syncing their parent tasks. I don't understand why their sync could be so much crappy when its simple logic that the parent tasks should be synched before the subtasks. FYI, I'm a Toodledo Pro user.

Any help will be appreciated a lot. Many Thanks.

Affly Aamy :-)

Posted: Jun 11, 2009
Score: 0

Todo is syncing fine for me. Are you sure there is no network issue?

Posted: Jun 11, 2009
Score: 0

No network issue Anders, I tried in other connections - my frnd's home and using 3G. Are you using subtasks in appigo todo. Is your tasks getting synched right without the Invalid Parent issue? Thanks.

I might consider that as a network issue if it happened only with wifi, but its happening even when I sync with 3G. I don't think it might be a coincidence becoz both my 3G and wifi are different service providers :-( Bad day for me.

Posted: Jun 12, 2009
Score: 0



In Appigo Todo Sync Settings,

Step 1: Switch Services to the Appigo Sync (for desktop) - Clears connection information for the current sync service, which is Toodledo

Step 2: Finished full sync with my desktop with Appigo sync application

Step 3: Switch Services back to Toodledo, now perform Full Sync - Successfully synhed - Happy ending! :-)

Step 4: I'm sitting confused what are all these funny workarounds!

But, still the issue with wifi exists (perfect sync works only with 3G in my iPhone). The wifi sync gives the same lost connection issue. But, at least my Toodledo is recovered. Good that I had my tasks backed up in Appigo Todo. But anyway, Toodledo did recover all my tasks but I wanted to start fresh from my iPhone data.

Moral of the Story - Its a funny day! No moral, Period!
You cannot reply yet

To participate in these forums, you must be signed in.

Toodledo Forums > Third-Party Applications