ForumsQuestionsneed help on "batch edit"


need help on "batch edit"
Author Message
jerryrau

Posted: Apr 03, 2019
Score: 0 Reference
Hi,

I'm a "light" toodledoo user for many years.
Just learned about batch edit mode.

Could NOT find any FAQ or help page :-(

I see the "batch edit this list" command under the down carrot at upper right but this appears to want to batch edit the entire list showing.

QUESTION: How do I select a subset of tasks to apply the batch edit to? I saw the demo doing just that in Aaron's blog today and I can not reproduce it. Typing "l" didn't do anything for me. This looks like a really useful feature for me - please help!

Thanks!
jerryrau

Posted: Apr 03, 2019
Score: 0 Reference
Never mind.... further clicking through the forums and I discovered that "Keyboard shortcuts" had to be enabled.
-J-O-D-

Posted: Apr 03, 2019
Score: 0 Reference
Also,it is L, just to make sure. not I (as in "I am").

Posted by jerryrau:
Never mind.... further clicking through the forums and I discovered that "Keyboard shortcuts" had to be enabled.
carol_3

Posted: Apr 04, 2019
Score: 0 Reference
Also - in case anyone besides me hadn't switched to the "new layout" yet -- the new Batch Edit feature seems to require that switch.
-J-O-D-

Posted: Apr 05, 2019
Score: 0 Reference
All development is now for new layout only. Recently, it was said that they may eventually get back to old layout, but if so, that would be after everything has been added/fixed/fixed again on the new layout. There is a reason, why it is called "legacy", afterall.

Posted by carol_3:
Also - in case anyone besides me hadn't switched to the "new layout" yet -- the new Batch Edit feature seems to require that switch.


This message was edited Apr 05, 2019.
Ob-La-Di+ruben

Posted: Apr 05, 2019
Score: 0 Reference
J-O-D - personally, I kind of like and feel the legacy UI is a bit of a security blanket and I'm happy and basically prefer if the new features are not implemented there and toodledo dev leaves it alone and as is.

Unless there are architectural changes which break the legacy UI (which are no doubt coming too at some point), right now I feel like I have the legacy UI to fall back on when things go haywire in the new UI. And given how it seems like features/new code are regularly rolled out and my sense that there doesn't seem to be a comprehensive, complete set of test suites put together to ensure that a new toodledo code set does not introduce regressions, and my concern that toodledo QA plan could possibly be just running some ad hoc tests upon feature implementation coupled with beta users, I find it comforting to know that I can jump back to legacy if need be. I'll have to put up with some gnats like reverse order of tag cloud (that was our original introduction when you pointed the switchover out to me) but that I can live with if I am otherwise blocked/bothered in the new UI.

Here is a pictorial representation of the discombobulated feeling I'm getting sometimes these days in the topsy turvy toodledo world of late...



This message was edited Apr 05, 2019.
-J-O-D-

Posted: Apr 05, 2019
Score: 0 Reference
rubenB, that is precisely why I am now using something different and I kept deleting my accounts - everytime things seem to improve, something happens and goes downhill. Like CTRL=>L>not possible to type L when adding tasks issue. I still have a special place for Toodledo in my heart, but I actually have to complete my tasks. Yeah, I feel Spaceballed too, sometimes.

BTW: It's not U.K. (luckily, due to recent brexmash), it's Czechia.


This message was edited Apr 05, 2019.
Ob-La-Di+ruben

Posted: Apr 05, 2019
Score: 0 Reference
We all need as much Schwartz as we can get these days, and I truly hope toodledo gets the biggest helping of all. I have a soft spot in my heart for TD, as well.

Ah, not in the Isles, eh? Yeah, lucky you as the Brits and their Brexit fun seem to be almost in a race with us to try and see who can be more dysfunctional, and here when I thought we had that title completely sewn up with no competition anywhere on the horizon.

But, on another note, how in the world did you pick up such fantastic English? Sure puts the rest of us to shame...


This message was edited Apr 05, 2019.
-J-O-D-

Posted: Apr 05, 2019
Score: 0 Reference
Thanks, I wouldn't agree with you on this, but thanks:-) Mostly by reading the Internet - because in my experience, best answers to any IT-based questions to be found are written in English. This has also made me to turn all my OS (Windows, iOs) into English (U.K., mainly because I don't like the oversea style of time and date notation;-) ). Because finding the answer in English really does not work well for localised software;-)

Anyway, I am now in situation that if I read an English text, I simply understand it, but when I have to explain someone, what that particular English word means, I don't know:-)

EDIT: Well, 4 years at school with 5 hours of English per week and a school-leaving exam also helps...

Posted by rubenB:
But, on another note, how in the world did you pick up such fantastic English? Sure puts the rest of us to shame...


This message was edited Apr 05, 2019.
luas

Posted: Apr 05, 2019
Score: 0 Reference
Hi,
I have the same issue. Euphorically read about batch edit mode in https://blog.toodledo.com/march-2019-monthly-update/, but can't get it to work.
Switched to new layout (which is - in my opinion - offered really coyly as "Want a preview?") and enabled keyboard shortcuts. Still, hitting "l" (L) has no effect. Any ideas?
-J-O-D-

Posted: Apr 05, 2019
Score: 0 Reference
When you hold L (not just tapping it) and left click tasks, these should get highlighted and the batch editing panel should open on right side of screen. It does for me.

Posted by luas:
Hi,
I have the same issue. Euphorically read about batch edit mode in https://blog.toodledo.com/march-2019-monthly-update/, but can't get it to work.
Switched to new layout (which is - in my opinion - offered really coyly as "Want a preview?") and enabled keyboard shortcuts. Still, hitting "l" (L) has no effect. Any ideas?


This message was edited Apr 05, 2019.
luas

Posted: Apr 05, 2019
Score: 0 Reference
Aaaah, thank you! It should probably say "press and hold" in the blog ;)
Purveyor

Posted: Apr 05, 2019
Score: 0 Reference
"L" shows up in the list of keyboard shortcuts but it doesn't do anything on its own.

All the other keystrokes do something when you press them. "L" does nothing, unless you click a task while pressing the "L".

Hidden and unintuitive.

And the use of the letter "L" has no connection to the action "Batch Edit".
-J-O-D-

Posted: Apr 05, 2019
Score: 0 Reference
That depends on a person - for me, holding and clicking to select is natural way, instead of toggling a mode on/off. Probably due to Windows and videogames experience.

That beeing said, and info in the popup "L - hold a click to batch select tasks" would be much better.


This message was edited Apr 05, 2019.
garyo

Posted: Apr 05, 2019
Score: 1 Reference
Note: holding L also scrolls your list up, if you have a list longer than the browser page. This is a bug. You can't multiselect from your list if it's long.
Multiselect has been my #1 request for many, many years and I'm excited to almost be able to use it. Just needs a more standard way to invoke -- sure, keep the kbd shortcut -- but also something easy & discoverable. My suggestion would be (assuming single-line task view) you hit a "multiselect" button on the top bar and a new column of checkboxes (styled differently) appears -- as you click those, the tasks turn yellow as they do now (that's great user feedback) and the multiselect dialog opens as it does now.
Ob-La-Di+ruben

Posted: Apr 05, 2019
Score: 0 Reference
Posted by luas:
Aaaah, thank you! It should probably say "press and hold" in the blog ;)


That would certainly make it clearer - as would a couple extra words to that effect in the shortcuts "help" which comes up when pressing '?'.

I guess I alone see this other problem? It's screwy block-of-text-selection highlighting when I use batch multi-edit, on either of two computers (win7 or win10 & different browsers) that I point to in my posting here along with the included screenshot.

Batch Edit Problems

Most strange since it seems that I must be doing something wrong since no one else sees this. But just "Push down and hold the 'L' key while clicking left mouse button on tasks to be multi-selected" seems too simple for me to be screwing up.


This message was edited Apr 05, 2019.
Ob-La-Di+ruben

Posted: Apr 05, 2019
Score: 0 Reference
Posted by garyo:
Note: holding L also scrolls your list up, if you have a list longer than the browser page. This is a bug. You can't multiselect from your list if it's long.
Multiselect has been my #1 request for many, many years and I'm excited to almost be able to use it.


I see that same problem as well, as I discuss in this other thread (also included above in previous posting). Another user (apois) first noted the problem, but now (in that other thread) he says it's fixed. Not fixed for me.

And I have a different problem no one else seems to see with blocks of text selected (turning blue) along with single task selected (which highlights in yellow) when mouse clicking (also elaborated on in thread mentioned in posting above).


This message was edited Apr 05, 2019.
Ob-La-Di+ruben

Posted: Apr 05, 2019
Score: 0 Reference
Posted by Purveyor:
Hidden and unintuitive.


Succinctly and well-put.


This message was edited Apr 05, 2019.
-J-O-D-

Posted: Apr 05, 2019
Score: 0 Reference
Based on comment to my support ticket, due to fixing the L blocked when adding tasks, they had to rewind to the scrolling isssue version - and that shoud be fixed in tomorrow's build.

Posted by rubenB:
Posted by garyo:
Note: holding L also scrolls your list up, if you have a list longer than the browser page. This is a bug. You can't multiselect from your list if it's long.
Multiselect has been my #1 request for many, many years and I'm excited to almost be able to use it.


I see that same problem as well, as I discuss in this other thread (also include above in previous posting). Another user (apois) first noted the problem, but now (in that other thread) he says it's fixed. Not fixed for me.

And I have a different problem no one else seems to see with blocks of text selected (turning blue) along with single task selected (which highlights in yellow) when mouse clicking.
You cannot reply yet

U Back to topic home

R Post a reply

To participate in these forums, you must be signed in.